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StampIt is a simple Adobe® Acrobat® utility I hacked together for stamping a PDF document with page
numbers (and any other fields or watermarks). It is free software distributed under the terms of the GNU
General Public License (see below). I needed this utility because I was assembling a number of PDF
documents from different authors into a single document. There is a commercially available Acrobat®
plugin to perform this task called StampPDF  but it costs US$150 which I consider outrageous given
what it does and considering the already outrageous cost of the Acrobat® package. My utility is an
extension of the CodeCuts Tip #48 for "Adding `stamps' or `watermarks' to your PDFs". All I've done
here is exploited the way that Acrobat® generates field names when it applies a template to a document.
For example, if a field named "pg" defined for a template named "stampTemplate" is applied to a
document, then the field name generated for the first page of the document will be
"P1.stampTemplate.pg", and it will be "P2.stampTemplate.pg" for the second page, and so on. Since the
field names generated for the stamped pages are known, then it is possible to set the default values for
these fields as they are generated. In this case the default value for the field is the page number of the
page the field appears on.

System Requirements
Acrobat Exchange® v4.0 or higher (also known simply as Acrobat®).●   

Download
You can download StampIt here. Note that if your browser has the Acrobat Reader plug-in installed then
you should choose to download the link as a file rather than simply clicking on the link.

Using StampIt
Open the PDF version of this document in Acrobat Exchange®.1.  
Add/move any fields on the “stampTemplate” template according to what you want to appear on
each page of your document.

Use “Tools -> Forms -> PageTemplates...” to reveal the “stampTemplate” template as the
last page of this document.

❍   

You can delete the existing “stampTemplate” and replace it with your own if you want to❍   

2.  
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include a custom watermark or somesuch. Ensure that this replacement template is called
“stampTemplate” (using “Tools -> Forms -> Page Templates…”).
If you want a page number to be stamped on the document then ensure that there is a
read-only text form field named “pg” on the template.

❍   

Make sure that “stampTemplate” is marked as hidden before stamping a document (using
“Tools -> Forms -> Page Templates…”)

❍   

Insert the document that you want to stamp after this document (using “Document -> Insert
Pages…”)

3.  

If you wish, customize the page number format and initial value using the form fields that appear
below the “StampIt!” button (below - in the PDF version of this document).

4.  

Click on the “StampIt!” button!5.  
Extract the stamped document from this document (using “Document -> Extract Pages…”
ensuring that the “Delete Pages After Extracting” box is checked), go to the window with the
extracted pages (using “Window -> Pages from StampIt”) and save the stamped document (using
“File -> Save As…”).

6.  

Improving StampIt
This is only a rudimentary utility that served my purpose perfectly, but could stand to be improved upon
in many ways. For example:

Users could add templates and then select which ones should be utilized via a forms listbox prior
to stamping;

●   

Users could enable or disable fields on a template prior to stamping.●   

I would be happy to maintain the utility and integrate any new features you add. Just send your improved
version to me via email.

Bugs
Let me know about them by email.

Version History
V0.6

Added support for formatting page number and setting initial page number value.●   

V0.5
Initial version.●   

License
StampIt - A Stamping Utility for PDF Documents
Copyright © 2000 Gregory W. Bond

This program is free software; you can redistribute it and/or modify it under the terms of the GNU
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General Public License as published by the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.  See the GNU General Public License for more details.

The GNU General Public License is located on the web at http://www.gnu.org/copyleft/gpl.html; or you
can get a copy from the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 
02111-1307, USA.

Adobe, Acrobat, and Acrobat Exchange are trademarks of Adobe Systems Incorporated.
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SPECIAL NEEDS

The Special Needs Housing Program provides funding to develop housing for persons with special needs.
Funding under the Special Needs Housing Program is limited to nonprofit agencies which have received a tax
exempt ruling from the Internal Revenue Service under Section 501c of the Internal Revenue Code.

In July 2000, the Office of Housing & Community Development (OHCD) received approval from the City of
Sarasota Commission and the Sarasota County Government Board of County Commissioners for their five year
Consolidated Plan.  The development of this plan included a citizen participation process led by a citizen advisory
committee who were selected by the City of Sarasota and Sarasota County Government.  Information pertaining
to the Special Needs Program as outlined in the strategic plan are tied to the elderly, frail elderly, persons with
physical disabilities, persons afflicted with mental illness, persons who are developmentally disabled, persons
with alcohol or drug addictions and persons with HIV/AIDS & their families.  In Fiscal Year 2001 and 2002,
funds were budgeted to assist persons with mental illnesses, developmentally disabled persons and persons with
HIV/AIDS & their families.

In Fiscal Year 2000, the Office of Housing & Community Development received an award from the Florida
Housing Coalition for it's innovative program to provide housing to developmentally disabled individuals and
families.

Housing Program Policy Guidelines for the Special Needs Housing Program were approved by the City of
Sarasota on January 16, 2001, and the Board of County Commissioners on January 23, 2001.  These guidelines
outlined program descriptions, eligibility requirements, program requirements, funds use, the application process
and other necessary information.

On March 16, 2001, three committees were established to review the applications requesting funding to build
housing for the developmentally disabled, persons with HIV/AIDS & their family and persons who are mentally
ill.  They recommended to the management group to award funding to the following non-profit agencies:

- Catholic Charities proposing housing for persons with HIV/AIDS & their families.
- Coalition to Assist Supported Living (CASL) proposing housing for persons who are developmentally disabled.
- Renaissance Manor & Coastal Recovery proposing housing for persons who are mentally ill.

(Note:  Administrative costs are shown in the SHIP Fund 165 under Cost Center 239000.)

Goal  - Healthy Neighborhoods and Businesses
To provide affordable housing for special needs persons.

Objectives
To provide for the development of 20 new units for developmentally disabled persons over the next 5 years.

To provide for the development of 12 new units for persons with mental illness over the next five years.

To provide for the development of 5 new units for persons with HIV/AIDS over the next 5 years.

Description Unit FY2000 FY2001 FY2002

Performance Measures

Output Measure
Housing units - developmentally disabled Number 9 10 5
Housing units - mentally ill Number 7 14 8
Housing units - HIV/AIDS Number n/a 0 8

Effectiveness Measure
Program participant satisfaction Percent n/a 85 90

Description of Operations



SPECIAL NEEDS

Cost Center Expenditures By Category
FY 2000

Actual
FY 2001

Budget
FY 2002

Continuation
FY 2002

Issues
FY2002

Totals

Transfer Expenditures 715,172 530,000 530,000530,000 0

Totals $715,172 $530,000 $530,000$530,000 $0

Personnel Summary
Actual Positions 0.000.00 0.00

Total
Revenue Summary

INTERGOVERNMENTAL 530,000

$530,000



WATER/SEWER CONNECTION

The Water & Sewer Connection Program was established to make available to low-income households the
opportunity to connect to central water and sewer service.  Assistance for this program is provided through the
State Housing Initiative Partnership Program (SHIP) which provides a zero percent interest loan, deferred until
the homeowner sells or transfers ownership, or the property is no longer the primary residence of the owner.
Mortgage documents are executed at the time of the assistance in the amount of the impact fees and the utility
connection costs.  Contractor fees for the connection are paid directly to the contractor and the impact fees are
paid directly to the appropriate utility franchise.  The homeowner is responsible for the payment of all utility
deposits and all monthly utility costs.  Additionally, all homeowner applicants must be current with their
city/county property taxes and utility payments.

Eligibility requirements for the Water & Sewer Connection Program are that the home be located in Sarasota
County, applicants must be the owner and the home must be their primary residence, value of the home including
the utility connection must not exceed $160,000, connection must be completed within three months of the
approval of the application and total household income must meet income limits.

Total household income must be less than the income limits shown below:
Household Size Maximum Income
 1 $ 28,300
 2 $ 32,300
 3 $ 36,350
 4 $ 40,400
 5 $ 43,650
 6 $ 46,850
 7 $ 50,100
 8 $ 53,350

In July 2000, the Office of Housing & Community Development (OHCD) received approval from the City of
Sarasota Commission and the Sarasota County Government Board of County Commissioners for their five year
Consolidated Plan.  The development of this plan included a citizen participation process led by a citizen advisory
committee, who were selected by the City of Sarasota and Sarasota County Government.  Information pertaining
to the Water & Sewer Connection Program as outlined in the strategic plan are tied to improving water quality
and safe sewage disposal for income-eligible residents throughout Sarasota County.  When the strategic plan was
written, the plan was to assist a minimum of 16 housing units with water & sewer connection.  During Fiscal Year
2000, 42 housing units were assisted with water & sewer connection and a projection of 41 housing units will be
assisted in Fiscal Year 2001.  In Fiscal Year 2001, Sarasota received $200,000 in drought assistance from the
Florida Housing Finance Corporation.  With this assistance, an additional 25 families received assistance.

The City of Sarasota, on April 2, 2001, and the Board of County Commissioners, on April 24, 2001, approved
Housing Program Policy Guidelines for the Water Sewer Program.  These guidelines proposed a change in the
maximum home value from $94,995 to $160,000.

(Note:  Administrative costs are shown in the SHIP Fund 165 under Cost Center 239000.)

Goal  - Healthy Neighborhoods and Businesses
To assist homeowners with the cost of connecting to a public or private utility system.

Objectives
To provide funding for the connection of homes to central water & sewer.

Description of Operations



WATER/SEWER CONNECTION

Description Unit FY2000 FY2001 FY2002

Performance Measures

Output Measure
Water & sewer connections funded Number 42 41 17

Effectiveness Measure
Customer satisfaction Percent n/a 90 95

Cost Center Expenditures By Category
FY 2000

Actual
FY 2001

Budget
FY 2002

Continuation
FY 2002

Issues
FY2002

Totals

Non Personal Expenditures 0 0 00 0
Transfer Expenditures 211,484 100,000 100,000100,000 0

Totals $211,484 $100,000 $100,000$100,000 $0

Personnel Summary
Actual Positions 0.000.00 0.00

Total
Revenue Summary

INTERGOVERNMENTAL 100,000

$100,000



HOME BUYER EDUCATION

The HomeBuyers Education Program was funded from the State Housing Initiative Housing Partnership Program
(SHIP) to provide educational information to all homebuyers.  The focus of this program is to improve
homebuyers' awareness of the home purchase process and the importance of long term planning necessary for
home ownership.  The length of the homebuyer class is five hours.  Topics discussed in the homebuyer education
class includes housing maintenance, foreclosure prevention and long range planning.

In July 2000, the Office of Housing & Community Development (OHCD) received approval from the City of
Sarasota Commission and the Sarasota County Government Board of County Commissioners for their five year
Consolidated Plan.  The development of this plan included a citizen participation process led by a citizen advisory
committee, who were selected by the City of Sarasota and Sarasota County Government.  The development of this
plan included the HomeBuyer Education Program and the topics outlined above.

On April 2, 2001, the City Commission approved a request from OHCD and General Services to have the City
negotiate a contract with Consumer Credit Counseling to provide the HomeBuyer Education classes and
authorizing the City Auditor & Clerk, along with the Mayor, to execute the contract.  The program will be paid
for with State Housing Initiative Partnership Program (SHIP) funds.  The approval was for a two year program
with an annual funding level of $50,000.  The program is now being implemented.

(Note:  Personnel  for monitoring this program is located in the State Housing Initiative Partnership Program Fund
165, Cost Center 239000.)

Goal  - Healthy Neighborhoods and Businesses
To assist first time homebuyers by providing homebuyer educational workshops.

Objectives
To provide education workshops for 700 first time homebuyer applicants.

Description Unit FY2000 FY2001 FY2002

Performance Measures

Output Measure
Participants attending workshops Number 747 700 700

Effectiveness Measure
Customer satisfaction Percent n/a 85 90

Cost Center Expenditures By Category
FY 2000

Actual
FY 2001

Budget
FY 2002

Continuation
FY 2002

Issues
FY2002

Totals

Non Personal Expenditures 0 50,000 50,00050,000 0
Transfer Expenditures 26,068 0 00 0

Totals $26,068 $50,000 $50,000$50,000 $0

Personnel Summary
Actual Positions 0.000.00 0.00

Description of Operations



HOME BUYER EDUCATION

Total
Revenue Summary

INTERGOVERNMENTAL 50,000

$50,000



HOUSING PARTNERSHIP

The Sarasota Office of Housing and Community Development (OHCD) partners with local non-profits and
Community Housing Development Organizations to develop affordable housing.  This program provides an
interest free loan to the non-profit organizations for the development of single family homes and then provides a
deep-subsidy second mortgage for the homebuyer, typically $20,000 at 0% interest, to assure an affordable home
payment.

In July 2000, the Office of Housing & Community Development received approval from the City of Sarasota
Commission and the Sarasota County Government Board of County Commissioners for their five year
Consolidated Plan.  The development of this plan included a citizen participation process led by a citizen advisory
committee, who were selected by the City of Sarasota and Sarasota County Government. The development of this
plan included using State Housing Initiative Partnership (SHIP) Funds, HOME funds and other funding sources to
develop 23 units of infill housing and to purchase 4 lots for the purpose of constructing 4 of the 23 housing units.
During Fiscal Year 2000, 24 housing units were completed and it is planned to develop 20 new housing units
during Fiscal Year 2001.

The City of Sarasota, on March 5, 2001, and the Board of County Commissioners, on March 13, 2001, approved
Housing Program Policy Guidelines for the Housing Partnership Program.  The guidelines were approved at the
respective commission meetings.  The majority of the guidelines for the Housing Partnership Program remained
unchanged, although some components were described in additional detail.  The major changes from previous
years include the maximum sale price of the home, which increased from $94,995 to $120,000 and setting a flat
developer rate that is paid to the non-profit for each home developed.

(Note:  Personnel funding for this program is located in the State Housing Initiative Partnership Program] Fund
165, Cost Center 239000 and the HOME Partnership Program Fund 108, Cost Center 239000.)

Goal  - Healthy Neighborhoods and Businesses
To assist in the development of affordable housing units by leveraging public funds with private funds.

Objectives
To fund non-profits to build affordable homes.

Description Unit FY2000 FY2001 FY2002

Performance Measures

Output Measure
Affordable houses developed Number 24 20 20

Effectiveness Measure
Customer satisfaction with program Percent n/a 90 95

Efficiency Measure
Percentage of purchase price
     funded with public money Percent 25 23 20

Description of Operations



HOUSING PARTNERSHIP

Cost Center Expenditures By Category
FY 2000

Actual
FY 2001

Budget
FY 2002

Continuation
FY 2002

Issues
FY2002

Totals

Non Personal Expenditures 0 0 00 0
Transfer Expenditures 1,856,885 1,424,850 724,850724,850 0

Totals $1,856,885 $1,424,850 $724,850$724,850 $0

Personnel Summary
Actual Positions 0.000.00 0.00

Total
Revenue Summary

INTERGOVERNMENTAL 724,850

$724,850



STOREFRONT PROJECTS

The Sarasota Consortium 2000-2005 Consolidated Plan outlines the expenditure of Community Development
Block Grant (CDBG) funds for the City of Sarasota.  One of the proposed categories of expenditures is for
Economic Development, with the following proposed allocation:

Fiscal Year 2000-2001: $   75,000
Fiscal Year 2001-2002: $   75,000
Fiscal Year 2002-2003: $   50,000
Fiscal Year 2003-2004: $ 100,000
Fiscal Year 2004-2005: $ 100,000

Five Year Total: $ 400,000

The first and second years of funding are designated for a storefront renovation program in designated
low-income commercial neighborhoods of the City.  The storefront renovation program is designed to provide
assistance to local businesses that serve at least 51 percent of the low-to-moderate income community.  Assistance
is restricted to façade improvements, the correction of code violations, improvements that make the facility
accessible for persons with disabilities and indirect costs related to these improvements such as engineering and
architectural expenses.  These restrictions are in accordance with Federal regulations which restrict the type of
assistance given to for-profit businesses.

A policy is currently under development that would provide businesses with an interest free loan to be repaid to
the City over a maximum of 20 years, depending on the amount of assistance provided to the business.  Once the
policy is adopted, the program can begin the process of soliciting applicants and rehabilitating storefronts.

Goal  - Healthy Neighborhoods and Businesses
To fund the revitalization of commercial districts in low income areas of the City.

Objectives
To assist privately owned businesses with 3 storefront improvements.

Description Unit FY2000 FY2001 FY2002

Performance Measures

Output Measure
Storefront improvements Number n/a 0 3

Effectiveness Measure
Percentage of total improvements funded
     with public money Percent n/a n/a 50
Customer satisfaction with program Percent n/a 85 90

Cost Center Expenditures By Category
FY 2000

Actual
FY 2001

Budget
FY 2002

Continuation
FY 2002

Issues
FY2002

Totals

Non Personal Expenditures 0 75,000 00 0
Transfer Expenditures 47,151 0 75,00075,000 0

Totals $47,151 $75,000 $75,000$75,000 $0

Description of Operations



STOREFRONT PROJECTS

Personnel Summary
Actual Positions 0.000.00 0.00

Total
Revenue Summary

INTERGOVERNMENTAL 75,000

$75,000
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